Cisco Nexus B22HP FEX Install

Written by Mo Elamin. Posted in Blog

Recently I had a opportunity to work with the new HP C7000 Chassis with fabric extender, the Nexus B22HP.  A fabric extender is a Cisco Nexus switch (typically a Nexus 2000) that is managed via an upstream Nexus 5500 switch.  It allows you to scale out your top of rack (TOR) switches and still manage them with a pair of end of row (EOR) switches such as the Nexus 5500.

B22HP Cisco and HP took that same logic and created the Nexus B22HP for TenGigabit Ethernet / Fibre-Channel over Ethernet connectivity in the HP C3000 and C7000 chassis.  It allows your network administrators to manage the HP chassis switch from the familiar NX-OS command line of the Nexus 5500s. The Nexus B22HP has 8 external TenGigabit Ethernet interfaces for uplinks and 16 internal TenGigabit Ethernet interfaces, one for each blade in the chassis.  The diagram below illustrates typical deployment scenarios of the Nexus B22HP as well as the Nexus 2000 (in the right-most two racks):  

Our deployment required that we insert the Nexus B22HP into IOM Bays 5 & 6 since they were empty; we verified that the CNA in the blades was in mezzanine slot 2.

 After installing the Nexus B22HPs and connecting them to the upstream Nexus 5548UPs, we were ready to configure them!  For reference, I used this Cisco guide to deploy the Nexus B22HPs.  The diagram below is a reference of the FEX numbers, port-channel numbers, VLANs and VSANs that we used:

  N5K-PROD01:

fex 120

pinning max-links 1

description “B22_IN_HP7000_SLOT5″

!

interface port-channel121

description B22_IN_HP7000_SLOT5

switchport mode fex-fabric

fex associate 120

!

interface Ethernet1/15

switchport mode fex-fabric

fex associate 120

channel-group 120

 

interface Ethernet1/16

switchport mode fex-fabric

fex associate 120

channel-group 120

  N5K-PROD02:

fex 121

pinning max-links 1

description “B22_IN_HP7000_SLOT6″

!

interface port-channel121

description B22_IN_HP7000_SLOT5

switchport mode fex-fabric

fex associate 121

!

interface Ethernet1/15

switchport mode fex-fabric

fex associate 121

channel-group 121

interface Ethernet1/16

switchport mode fex-fabric

fex associate 121

channel-group 121

Tags: ,

Leave a comment

Built with HTML5 and CSS3
Copyright © 2012 Virtual Valley